import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SMS_TRIGGER:\\s([a-zA-Z0-9\\-]+).*SOURCE:\\s?([a-zA-Z]+).*";
final String string = "SMS_TRIGGER: c12a460d-0476-40ab-a0ee-0f8a2a16f73b was fired for SOURCE: PT";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}