$re = '/SMS_TRIGGER:\s([a-zA-Z0-9\-]+).*SOURCE:\s?([a-zA-Z]+).*/';
$str = 'SMS_TRIGGER: c12a460d-0476-40ab-a0ee-0f8a2a16f73b was fired for SOURCE: PT';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);