use strict;
my $str = 'SMS_TRIGGER: c12a460d-0476-40ab-a0ee-0f8a2a16f73b was fired for SOURCE: PT';
my $regex = qr/SMS_TRIGGER:\s([a-zA-Z0-9\-]+).*SOURCE:\s?([a-zA-Z]+).*/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}