package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^39,|,39$)`)
var str = `# тут нужно найти ,39 в конце или в начале строки
60,15,22,39
39,60,15,22
60,39,15,22
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}