re = /(^39,|,39$)/m
str = '# тут нужно найти ,39 в конце или в начале строки
60,15,22,39
39,60,15,22
60,39,15,22
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end