const regex = /(^39,|,39$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^39,|,39$)', 'gm')
const str = `# тут нужно найти ,39 в конце или в начале строки
60,15,22,39
39,60,15,22
60,39,15,22
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}