$re = '/(^39,|,39$)/m';
$str = '# тут нужно найти ,39 в конце или в начале строки
60,15,22,39
39,60,15,22
60,39,15,22
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);