using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)\R+|New:\R+)\K.+(?!\R+\w+:\R)";
string input = @"
New:
Remote_UI: Apple CarPlay application cannot be started (P3_DA18018395_012) (91735)
Media: After an iPhone is authorised as BTA device for the first time, Entertainment volume is abruptly set to zero when the user picks a song from ""Current tracklist"" (DA18018395_015)
Known:
HWR in navigation entry is not read out (89412)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}