#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!https:|http:)//\s*((?:https?://|(?!//).)*)(?<!\s)\s*//"
Local $sString = "test //ita https://example.com lics// test // another // one" & @CRLF & _
"" & @CRLF & _
"test //ita https://example.com lics this is a test https://example.com lics test / another // one" & @CRLF & _
"" & @CRLF & _
"test ita https://example.com //lics// test // another // one"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")