re = /(?<!https:|http:)\/\/\s*((?:https?:\/\/|(?!\/\/).)*)(?<!\s)\s*\/\//m
str = 'test //ita https://example.com lics// test // another // one
test //ita https://example.com lics this is a test https://example.com lics test / another // one
test ita https://example.com //lics// test // another // one'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end