const regex = new RegExp('(?<!https:|http:)//\\s*((?:https?://|(?!//).)*)(?<!\\s)\\s*//', 'gm')
const str = `test //ita https://example.com lics// test // another // one
test //ita https://example.com lics this is a test https://example.com lics test / another // one
test ita https://example.com //lics// test // another // one`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}