#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<img[^>]+\>"
Local $sString = "<p><i>O Armário Amapá da Politorno, essencial e indispensável quando se trata de organização e bom gosto.</i></p>" & @CRLF & _
"<p>Disponível na cor:</p>" & @CRLF & _
"<p><img class="alignnone" style="display: block; margin-bottom: 30px;" src="https://www.solinemoveis.com.br/wp-content/uploads/2012/09/cores-de-madeira-branco.jpg" alt="cores-de-madeira-branco" width="153" height="189"></p>" & @CRLF & _
"<h4>Dimensões do Armário <strong> ARMP3-019 </strong>Amapá:</h4>" & @CRLF & _
"<p><img style="display: block; margin-bottom: 30px;" src="https://www.solinemoveis.com.br/wp-content/uploads/2012/09/armario-organizador-amapa-branco-politorno-dimensoes1.jpg" alt="armario-organizador-amapa-branco-politorno-dimensoes1"></p>" & @CRLF & _
"<p>Visite também nossa página no facebook: https://www.facebook.com/solinemoveis/</p>" & @CRLF & _
"<p><a href="http://www.soline.com.br"><br>" & @CRLF & _
"<img class="alignright size-medium" src="https://www.solinemoveis.com.br/wp-content/uploads/2014/09/visite-loja-online-button-soline-moveis-soline.png" alt="Armário Amapá" width="179" height="74"><br>" & @CRLF & _
"</a></p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")