import Foundation
let pattern = #"<img[^>]+\>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<p><i>O Armário Amapá da Politorno, essencial e indispensável quando se trata de organização e bom gosto.</i></p>
<p>Disponível na cor:</p>
<p><img class="alignnone" style="display: block; margin-bottom: 30px;" src="https://www.solinemoveis.com.br/wp-content/uploads/2012/09/cores-de-madeira-branco.jpg" alt="cores-de-madeira-branco" width="153" height="189"></p>
<h4>Dimensões do Armário <strong> ARMP3-019 </strong>Amapá:</h4>
<p><img style="display: block; margin-bottom: 30px;" src="https://www.solinemoveis.com.br/wp-content/uploads/2012/09/armario-organizador-amapa-branco-politorno-dimensoes1.jpg" alt="armario-organizador-amapa-branco-politorno-dimensoes1"></p>
<p>Visite também nossa página no facebook: https://www.facebook.com/solinemoveis/</p>
<p><a href="http://www.soline.com.br"><br>
<img class="alignright size-medium" src="https://www.solinemoveis.com.br/wp-content/uploads/2014/09/visite-loja-online-button-soline-moveis-soline.png" alt="Armário Amapá" width="179" height="74"><br>
</a></p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)