import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "_([_\\d]*)[.]";
final String string = "myimage_1.jpg\n"
+ "myimage_1_1.jpg\n"
+ "myimage_1_1_1.jpg\n"
+ "myimage_1_1_1_1.jpg\n"
+ "myimage_1_1_1_1_1.jpg\n"
+ "anynumber_1_2_3_4_5_6.jpg\n"
+ "numbers_only_not_text_1.jpg\n"
+ "numbers_only_not_text_1_1.jpg\n\n"
+ "The '\\d' could purely be replaced with '1' if that is all that is required to be removed.\n\n"
+ "Ensure to replace matached string with a further '.'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}