// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"_([_\d]*)[.]").unwrap();
let string = "myimage_1.jpg
myimage_1_1.jpg
myimage_1_1_1.jpg
myimage_1_1_1_1.jpg
myimage_1_1_1_1_1.jpg
anynumber_1_2_3_4_5_6.jpg
numbers_only_not_text_1.jpg
numbers_only_not_text_1_1.jpg
The '\\d' could purely be replaced with '1' if that is all that is required to be removed.
Ensure to replace matached string with a further '.'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}