$re = '/_([_\d]*)[.]/';
$str = 'myimage_1.jpg
myimage_1_1.jpg
myimage_1_1_1.jpg
myimage_1_1_1_1.jpg
myimage_1_1_1_1_1.jpg
anynumber_1_2_3_4_5_6.jpg
numbers_only_not_text_1.jpg
numbers_only_not_text_1_1.jpg
The \'\\d\' could purely be replaced with \'1\' if that is all that is required to be removed.
Ensure to replace matached string with a further \'.\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);