import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:google|yahoo)(?:\\.com)?";
final String string = " I like foobar.com\n"
+ " I like google.com and foobar.com\n"
+ " I like foobar.com and google.com\n"
+ " I like foobargoogle.com and googlefoobar.com\n"
+ " I like yahoo.com and foobar.com\n"
+ " I like foobar.com and yahoo.com\n"
+ " I like foobaryahoo.com and yahoofoobar.com\n\n\n"
+ " I like yahoo.com\n"
+ " I like foobaryahoo.com\n"
+ " I like google.com\n"
+ " I like foobargoogle.com\n"
+ " I like google.com and yahoo.com\n"
+ " I like foobargoogle.com and foobaryahoo.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}