$re = '/(?:google|yahoo)(?:\.com)?/m';
$str = ' I like foobar.com
I like google.com and foobar.com
I like foobar.com and google.com
I like foobargoogle.com and googlefoobar.com
I like yahoo.com and foobar.com
I like foobar.com and yahoo.com
I like foobaryahoo.com and yahoofoobar.com
I like yahoo.com
I like foobaryahoo.com
I like google.com
I like foobargoogle.com
I like google.com and yahoo.com
I like foobargoogle.com and foobaryahoo.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);