use strict;
my $str = ' I like foobar.com
I like google.com and foobar.com
I like foobar.com and google.com
I like foobargoogle.com and googlefoobar.com
I like yahoo.com and foobar.com
I like foobar.com and yahoo.com
I like foobaryahoo.com and yahoofoobar.com
I like yahoo.com
I like foobaryahoo.com
I like google.com
I like foobargoogle.com
I like google.com and yahoo.com
I like foobargoogle.com and foobaryahoo.com
';
my $regex = qr/(?:google|yahoo)(?:\.com)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}