const regex = /(?:google|yahoo)(?:\.com)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:google|yahoo)(?:\\.com)?', 'gm')
const str = ` I like foobar.com
I like google.com and foobar.com
I like foobar.com and google.com
I like foobargoogle.com and googlefoobar.com
I like yahoo.com and foobar.com
I like foobar.com and yahoo.com
I like foobaryahoo.com and yahoofoobar.com
I like yahoo.com
I like foobaryahoo.com
I like google.com
I like foobargoogle.com
I like google.com and yahoo.com
I like foobargoogle.com and foobaryahoo.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}