package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^[0-9a-zA-Z]+(,[0-9a-zA-Z]+){0,11}$`)
var str = `1
1a,q2,12,12,12,12,12,12,12,12,12,12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}