$re = '/^[0-9a-zA-Z]+(,[0-9a-zA-Z]+){0,11}$/im';
$str = '1
1a,q2,12,12,12,12,12,12,12,12,12,12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);