// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^[0-9a-zA-Z]+(,[0-9a-zA-Z]+){0,11}$").unwrap();
let string = "1
1a,q2,12,12,12,12,12,12,12,12,12,12";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}