re = /^[0-9a-zA-Z]+(,[0-9a-zA-Z]+){0,11}$/im
str = '1
1a,q2,12,12,12,12,12,12,12,12,12,12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end