#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d{3}([-\s\.])?\d{3}\1?\d{4}"
Local $sString = "111-222.3333" & @CRLF & _
"111.222-3333" & @CRLF & _
"111-222 3333" & @CRLF & _
"111 222-3333" & @CRLF & _
"111-222-3333" & @CRLF & _
"111.222.3333" & @CRLF & _
"111 222 3333"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")