$re = '/\d{3}([-\s\.])?\d{3}\1?\d{4}/';
$str = '111-222.3333
111.222-3333
111-222 3333
111 222-3333
111-222-3333
111.222.3333
111 222 3333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);