using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{3}([-\s\.])?\d{3}\1?\d{4}";
string input = @"111-222.3333
111.222-3333
111-222 3333
111 222-3333
111-222-3333
111.222.3333
111 222 3333";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}