using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\W+";
string substitution = @"_";
string input = @"Gem. Buitentemperatuur (etmaal)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}