$re = '/\W+/';
$str = 'Gem. Buitentemperatuur (etmaal)';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;