const regex = /\W+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\W+', 'g')
const str = `Gem. Buitentemperatuur (etmaal)`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);