import re
regex = re.compile(r"^user\/[0-9A-F]{8}-[0-9A-F]{4}-[4][0-9A-F]{3}-[89AB][0-9A-F]{3}-[0-9A-F]{12}(?:\/.*)?$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("user/a24a6ea4-ce75-4665-a070-57453082c256\n"
"user/a24a6ea4-ce75-4665-a070-57453082c256/photo\n"
"user/a24a6ea4-ce75-4665-a070-57453082c256asdasd")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")