re = /^user\/[0-9A-F]{8}-[0-9A-F]{4}-[4][0-9A-F]{3}-[89AB][0-9A-F]{3}-[0-9A-F]{12}(?:\/.*)?$/im
str = 'user/a24a6ea4-ce75-4665-a070-57453082c256
user/a24a6ea4-ce75-4665-a070-57453082c256/photo
user/a24a6ea4-ce75-4665-a070-57453082c256asdasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end