// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^user\/[0-9A-F]{8}-[0-9A-F]{4}-[4][0-9A-F]{3}-[89AB][0-9A-F]{3}-[0-9A-F]{12}(?:\/.*)?$").unwrap();
let string = "user/a24a6ea4-ce75-4665-a070-57453082c256
user/a24a6ea4-ce75-4665-a070-57453082c256/photo
user/a24a6ea4-ce75-4665-a070-57453082c256asdasd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}