#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iu)(?P<LongDate>(?P<Day>\d+)\.?[\s ]*(?P<Month>tammikuuta|tammikuu|tammikuineni|helmikuineni|helmikuuta|helmikuu|maaliskuuta|maaliskuineni|maaliskuu|huhtihuineni|huhtikuuta|huhtikuu|toukokuineni|toukokuuta|toukokuu|kesäkuineni|kesäkuuta|kesäkuu|heinäkuineni|heinäkuuta|heinäkuu|elokuineni|elokuuta|elokuu|syyskuineni|syyskuuta|syyskuu|lokakuineni|lokakuuta|lokakuu|marraskuineni|marraskuuta|marraskuu|joulukuineni|joulukuuta|joulukuu|\d+)\.?[\s ]*(?P<Year>\d{4}))"
Local $sString = "Cresson, 11.7.2006 antamassaan" & @CRLF & _
" tuomio 18.12.2008, Kok."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")