# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<LongDate>(?P<Day>\d+)\.?[\s ]*(?P<Month>tammikuuta|tammikuu|tammikuineni|helmikuineni|helmikuuta|helmikuu|maaliskuuta|maaliskuineni|maaliskuu|huhtihuineni|huhtikuuta|huhtikuu|toukokuineni|toukokuuta|toukokuu|kesäkuineni|kesäkuuta|kesäkuu|heinäkuineni|heinäkuuta|heinäkuu|elokuineni|elokuuta|elokuu|syyskuineni|syyskuuta|syyskuu|lokakuineni|lokakuuta|lokakuu|marraskuineni|marraskuuta|marraskuu|joulukuineni|joulukuuta|joulukuu|\d+)\.?[\s ]*(?P<Year>\d{4}))"
test_str = ("Cresson, 11.7.2006 antamassaan\n"
" tuomio 18.12.2008, Kok.")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.