package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?P<LongDate>(?P<Day>\d+)\.?[\s ]*(?P<Month>tammikuuta|tammikuu|tammikuineni|helmikuineni|helmikuuta|helmikuu|maaliskuuta|maaliskuineni|maaliskuu|huhtihuineni|huhtikuuta|huhtikuu|toukokuineni|toukokuuta|toukokuu|kesäkuineni|kesäkuuta|kesäkuu|heinäkuineni|heinäkuuta|heinäkuu|elokuineni|elokuuta|elokuu|syyskuineni|syyskuuta|syyskuu|lokakuineni|lokakuuta|lokakuu|marraskuineni|marraskuuta|marraskuu|joulukuineni|joulukuuta|joulukuu|\d+)\.?[\s ]*(?P<Year>\d{4}))`)
var str = `Cresson, 11.7.2006 antamassaan
tuomio 18.12.2008, Kok.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}