const regex = new RegExp('(?P<LongDate>(?P<Day>\\d+)\\.?[\\s ]*(?P<Month>tammikuuta|tammikuu|tammikuineni|helmikuineni|helmikuuta|helmikuu|maaliskuuta|maaliskuineni|maaliskuu|huhtihuineni|huhtikuuta|huhtikuu|toukokuineni|toukokuuta|toukokuu|kesäkuineni|kesäkuuta|kesäkuu|heinäkuineni|heinäkuuta|heinäkuu|elokuineni|elokuuta|elokuu|syyskuineni|syyskuuta|syyskuu|lokakuineni|lokakuuta|lokakuu|marraskuineni|marraskuuta|marraskuu|joulukuineni|joulukuuta|joulukuu|\\d+)\\.?[\\s ]*(?P<Year>\\d{4}))', 'giu')
const str = `Cresson, 11.7.2006 antamassaan
tuomio 18.12.2008, Kok.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}