import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<expressaocompleta>(?:^|\\s)(?<tipojoin>right|inner|left)\\sjoin\\s(?<tabelasjoin>.*)\\son\\s(?<clausulas>.*(?<fatorcondicional>inner|right|where(?<condicao>.*))?))$";
final String string = "SELECT a, b, c, de, efe \n"
+ "FROM aaa a, bbb b \n"
+ "inner join aaa aa ON aa = aaa \n"
+ "right join vvv aac On vvv.asdw = adadw AND ccc = aadw \n"
+ "left join aaaa aa On aaa = sss WHERE a = 'aa'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}