re = /^(?<expressaocompleta>(?:^|\s)(?<tipojoin>right|inner|left)\sjoin\s(?<tabelasjoin>.*)\son\s(?<clausulas>.*(?<fatorcondicional>inner|right|where(?<condicao>.*))?))$/mi
str = 'SELECT a, b, c, de, efe
FROM aaa a, bbb b
inner join aaa aa ON aa = aaa
right join vvv aac On vvv.asdw = adadw AND ccc = aadw
left join aaaa aa On aaa = sss WHERE a = \'aa\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end