import re
regex = re.compile(r"^(?<expressaocompleta>(?:^|\s)(?<tipojoin>right|inner|left)\sjoin\s(?<tabelasjoin>.*)\son\s(?<clausulas>.*(?<fatorcondicional>inner|right|where(?<condicao>.*))?))$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("SELECT a, b, c, de, efe \n"
"FROM aaa a, bbb b \n"
"inner join aaa aa ON aa = aaa \n"
"right join vvv aac On vvv.asdw = adadw AND ccc = aadw \n"
"left join aaaa aa On aaa = sss WHERE a = 'aa'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")