import Foundation
let pattern = #"^(?<expressaocompleta>(?:^|\s)(?<tipojoin>right|inner|left)\sjoin\s(?<tabelasjoin>.*)\son\s(?<clausulas>.*(?<fatorcondicional>inner|right|where(?<condicao>.*))?))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
SELECT a, b, c, de, efe
FROM aaa a, bbb b
inner join aaa aa ON aa = aaa
right join vvv aac On vvv.asdw = adadw AND ccc = aadw
left join aaaa aa On aaa = sss WHERE a = 'aa'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)