use strict;
my $str = 'F21W2121/02';
my $regex = qr/^((((([A-Z])\d+)[A-Z])\d+)/\d+)$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";