import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:([1-9]?[0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\\.){3}(?1)$";
final String string = "0.0.0.0\n"
+ "0.0.0.1\n"
+ "0.0.0.9\n"
+ "0.0.0.19\n"
+ "0.0.0.29\n"
+ "0.0.0.39\n"
+ "0.0.0.49\n"
+ "0.0.0.59\n"
+ "0.0.0.69\n"
+ "0.0.0.79\n"
+ "0.0.0.89\n"
+ "0.0.0.99\n"
+ "0.0.0.100\n"
+ "0.0.0.109\n"
+ "0.0.0.199\n"
+ "0.0.0.200\n"
+ "0.0.0.209\n"
+ "0.0.0.210\n"
+ "0.0.0.219\n"
+ "0.0.0.229\n"
+ "0.0.0.239\n"
+ "0.0.0.249\n"
+ "0.0.0.250\n"
+ "0.0.0.251\n"
+ "0.0.0.253\n"
+ "0.0.0.254\n"
+ "0.0.0.255\n"
+ "0.0.0.256\n"
+ "127.0.0.1\n"
+ "255.255.255.0\n"
+ "192.168.0.1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}