const regex = /^(?:([1-9]?[0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}(?1)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:([1-9]?[0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\\.){3}(?1)$', 'gm')
const str = `0.0.0.0
0.0.0.1
0.0.0.9
0.0.0.19
0.0.0.29
0.0.0.39
0.0.0.49
0.0.0.59
0.0.0.69
0.0.0.79
0.0.0.89
0.0.0.99
0.0.0.100
0.0.0.109
0.0.0.199
0.0.0.200
0.0.0.209
0.0.0.210
0.0.0.219
0.0.0.229
0.0.0.239
0.0.0.249
0.0.0.250
0.0.0.251
0.0.0.253
0.0.0.254
0.0.0.255
0.0.0.256
127.0.0.1
255.255.255.0
192.168.0.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}