package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d{1,2}(?::\d\d)?(?:\s?| )[ap]\.?m\b`)
var str = `Match: 10pm<br>
Match: 10 pm `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}