$re = '/\b\d{1,2}(?::\d\d)?(?:\s?| )[ap]\.?m\b/m';
$str = 'Match: 10pm<br>
Match: 10 pm ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);