// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b\d{1,2}(?::\d\d)?(?:\s?| )[ap]\.?m\b").unwrap();
let string = "Match: 10pm<br>
Match: 10 pm ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}