re = /\b\d{1,2}(?::\d\d)?(?:\s?| )[ap]\.?m\b/m
str = 'Match: 10pm<br>
Match: 10 pm '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end