#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d\s)(?<!\d)(mil)\b"
Local $sString = "esta a mil o a 25 mil 500 millas de la ciudad de milan" & @CRLF & _
"mil o mas para pasar! y tu tienes menos de mil" & @CRLF & _
"hace casi mil o 2mil anos aparecio un fenomeno legendario tan solo a millas de aqui"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")