using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d\s)(?<!\d)(mil)\b";
string input = @"esta a mil o a 25 mil 500 millas de la ciudad de milan
mil o mas para pasar! y tu tienes menos de mil
hace casi mil o 2mil anos aparecio un fenomeno legendario tan solo a millas de aqui";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}